Jump to content
Customer Service 866.965.0400
  • 0

Just Made the Jump on the FLEX


DTrem13
 Share

Question

And I CAN NOT WAIT for it to get here :willy: :willy:

 

I've been thinking about it for a while, and I decided it's finally time to upgrade. After all I've heard from everyone here, it'll make polishing so much faster and easier compared to the Porter Cable.

 

Seriously I'm so psyched to try this bad boy out. Too bad it's still winter here, and the temperatures haven't been getting much higher than 25 degrees lately. But I'm sure I'll find a way to use it. I do have a heated garage after all.

 

I'm getting such a bad case of cabin fever lately. I can't get wait to get back on my detailing grind!! I have so many cars lined up to polish up once this snow and salt go away for a while. It's gonna drive me insane! :help:

Link to comment
Share on other sites

21 answers to this question

Recommended Posts

  • 0

Great choice you'll be very happy!!!!!! I got mine about a month ago and was going through the same thing. I live about 30 miles northwest of Chicago and the weather here really sucks now. I tried to wait to use it, until the weather broke, but the suspense was killing me. So I waited until it was a little warmer day[in the thirties] and cracked it out in my garage, which is not heated. WOW, it was like shooting a load. Enjoy man!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Link to comment
Share on other sites

  • 0
Anyone had a problem with the Flex like not getting full power,,, when using it, squeeze the trigger and like it is running on half power, then all the sudden wham it kicks in, the other times seems to run good?????

 

Nope. It does phase into full power, but 'Wham' to full power sounds like a defective trigger or speed selector switch. Does it do that regardless of the speed you have selected?

Link to comment
Share on other sites

  • 0
Anyone had a problem with the Flex like not getting full power,,, when using it, squeeze the trigger and like it is running on half power, then all the sudden wham it kicks in, the other times seems to run good?????

 

I did not notice that with mine.

Link to comment
Share on other sites

  • 0
Nope. It does phase into full power, but 'Wham' to full power sounds like a defective trigger or speed selector switch. Does it do that regardless of the speed you have selected?

 

I will try it again tonight,, pull the trigger easy,,, then all the way and it stayed same speed then went to full speed,, had it set on 5. A cat here at work suggested maybe the extension cord could be faulty. :patriot:

Link to comment
Share on other sites

  • 0
I will try it again tonight,, pull the trigger easy,,, then all the way and it stayed same speed then went to full speed,, had it set on 5. A cat here at work suggested maybe the extension cord could be faulty. :patriot:

 

Don't listen to cats at work. They don't know Jack about a Flex. :lolsmack:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...