Jump to content
Customer Service 866.965.0400
  • 0

Ceramic Boost 2.0


Ls1transam
 Share

Question

How many of you have used it in cooler temps? I tried it today and it’s around 50 here in Ky. I tried it on my coated daily and a non coated car and had the same results. It just smeared and smeared. Didn’t matter how much I used, it’s like I was just moving it around on the surface. Wondering if cooler temps are to blame.

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 0
1 hour ago, Ls1transam said:

How many of you have used it in cooler temps? I tried it today and it’s around 50 here in Ky. I tried it on my coated daily and a non coated car and had the same results. It just smeared and smeared. Didn’t matter how much I used, it’s like I was just moving it around on the surface. Wondering if cooler temps are to blame.

Haven’t had an issue,  what towel were you using?

Link to comment
Share on other sites

  • 0

Sometimes if I use guard and gloss or Boost on my work vehicles that don’t have the best paint, sit outside, and I don’t do a proper strip/clay prior, I can get streaky finish sometimes.  But on my newer more well cared for vehicles it works flawlessly. Could that be the issue possibly you are having?

Link to comment
Share on other sites

  • 0

 My personal opinion is that H2O and CB don't play nice with SOME other product that may still be on the vehicle. 

 

 When I first started using H2O I had a very similar experience. Just streaked and laid on the surface like snot. After complete strip and then laying down lps the H2O goes on smooth as silk and flashes right off. My take away was that the wax from another company was what initially caused the weird reaction. 

 

 Have you taken your vehicle to a pay and spray or no touch auto wash recently? I think some of their "wax" and soaps can cause havoc with certain products. 

Edited by Velvethelmet
Link to comment
Share on other sites

  • 0
1 hour ago, bjoeaull said:

Sometimes if I use guard and gloss or Boost on my work vehicles that don’t have the best paint, sit outside, and I don’t do a proper strip/clay prior, I can get streaky finish sometimes.  But on my newer more well cared for vehicles it works flawlessly. Could that be the issue possibly you are having?

 

1 hour ago, bjoeaull said:

Sometimes if I use guard and gloss or Boost on my work vehicles that don’t have the best paint, sit outside, and I don’t do a proper strip/clay prior, I can get streaky finish sometimes.  But on my newer more well cared for vehicles it works flawlessly. Could that be the issue possibly you are having?

 I stripped a panel and tried it. Didn’t polish but stripped all prior protection off. Also tried it on a Ceramic coated vehicle. Non Adams coating but, the results were the same. I used another brand of silica spray and had zero issues with it.

Link to comment
Share on other sites

  • 0
35 minutes ago, Ls1transam said:

 

 I stripped a panel and tried it. Didn’t polish but stripped all prior protection off. Also tried it on a Ceramic coated vehicle. Non Adams coating but, the results were the same. I used another brand of silica spray and had zero issues with it.

 

As you know, Adam's products may not play nicely with other coatings. And vice versa. Not surprised to hear it may not have worked well on the coated one.

 

You may have gotten a bad batch. Did you call to get a replacement?

Link to comment
Share on other sites

  • 0
48 minutes ago, falcaineer said:

 

As you know, Adam's products may not play nicely with other coatings. And vice versa. Not surprised to hear it may not have worked well on the coated one.

 

You may have gotten a bad batch. Did you call to get a replacement?

 Yea with same results. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...