Jump to content
Customer Service 866.965.0400
  • 0

All purpose cleaner - Help?


myturn89
 Share

Question

So i used the all purpose cleaner on my 89 vette rims. i think i left the cleaner on too long and it looks like i burned through some of the clearcoating or something on the rims. i have "white clouding" drip like marks on the rims. Any ideas, suggestions to clean this back to normal? hopefully something can be done.....:confused:

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Do you have any revive polish ? If not try some SHR by hand.

 

 

But that should come right off, if you don't have either of those try cutting some apc 50/50 with water and wipe them down and rinse them right off.

Link to comment
Share on other sites

  • 0

Hi Rez, and sorry to hear about this. I've seen many, many sets of your wheels get cloudy clear coats, and know exactly what you are speaking of.

 

Like Bill mentioned, a little polish will likely do the trick. Were the wheels cold to the touch when you used the APC, and how long did it set on before you washed or hosed it off?

 

Again, try the polish, and please get back with your replies when you can.

 

Thanks! -Adam:thumbsup:

Link to comment
Share on other sites

  • 0

adam thanks for the response. i don't believe the wheels were cold, but i know that they were not hot, so i am sure that does not help in answering the question. the car was outside on a warm (70's) day for about 2 hours prior to cleaning the wheels.

Also, i left it on long enough to do all of the wheels prior to rinsing, not sure why i did that but just did. i will have to buy some polish and try out the fix........

Link to comment
Share on other sites

  • 0
adam thanks for the response. i don't believe the wheels were cold, but i know that they were not hot, so i am sure that does not help in answering the question. the car was outside on a warm (70's) day for about 2 hours prior to cleaning the wheels.

Also, i left it on long enough to do all of the wheels prior to rinsing, not sure why i did that but just did. i will have to buy some polish and try out the fix........

 

Thanks Rez, and by hot, I meant recently driven. Shoot me an email or phone call, and let's review the plan to get your wheels perfect again.

 

Adam@AdamsPolishes.com, or, 303-997-4374

 

Thanks again Rez!:2thumbs:

Link to comment
Share on other sites

  • 0

Rez....is the clear coat starting to show sign's of peeling?

My 90 wheels had some bad area's with the clear coat and I ended up stripping them and getting them clear coated again...then I sold her :willy:

Do you have any pic's of the wheels?

Link to comment
Share on other sites

  • 0

Thanks to everyone for all of the posts and thanks to Adam for the phone call and suggestions. Below is what was my direction:

 

1) Start with FMP and see what the results are. No real exciting results.

 

2) Move to SHR. This did the trick. Please be kind (if i get these photos uploaded), the Detroit Red Wings were on so i did this in-between periods and need to now move to the whole wheel i just did a test spot.

 

Thanks everyone and thanks for the forum!

 

BEFORE:

picture.php?albumid=201&pictureid=1186

 

AFTER:

picture.php?albumid=201&pictureid=1187

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...